Możesz spotkać się z kodem błędu wskazującym, że nie znaleziono konkretnego polecenia autoreconf związanego z mac os x. Istnieje wiele sposobów rozwiązania tego problemu, również omówimy je krótko.

Jaki masz problem z komputerem? Rozwiąż je wszystkie jednym kliknięciem dzięki najlepszemu narzędziu do naprawy systemu Windows.

Jeśli generujesz brew i autoreconf jest częścią usługi połączoną z pakietem autoconf , wdróż witrynę poprzez:

  make install autoconf 

Jeśli problem nie ustąpi, powinieneś rozważyć ponowne zainstalowanie linków lub . Użyj locate autoreconf find, gdy chcesz dowiedzieć się, gdzie to jest.

Upewnij się również, że usr / local / bin i autoreconf istnieje (i jest połączony z odpowiednią lokalizacją) i że większość z was ma - usr / local / bin < /code> Dodano dostęp do ścieżki / etc / paths , w tym twój cenny plik.

Aktualizacja: po prostu użyj Homebrew, aby zainstalować te systemy i żyć dalej.

Zainstaluj Homebrew i po prostu zainstaluj każdy autoconf , automake w połączeniu z nawet pakietami wakacyjnymi libtool takimi jak ten

  brew instalacja autoconf automake libtool 

Kiedy odpowiedziałem ponad 3 lata temu, pomysł polegał na naprawieniu rozwiązania z wyprzedzeniem, które było nieaktualne, zawierało oprócz linków i nie zostało wyjaśnione w wyjaśnieniu. W tamtym czasie wolałem używać Biblioteki Raw Source w systemie MacOS do techniki podobnej do techniki lidera zespołu opcji, takiego jak Homebrew, ponieważ Ale okazało się, że w tamtym czasie Homebrew i Fabulous MacPorts są trochę przedwczesne.

Zacząłem teraz regularnie używać Homebrew (znanego również ze względu na to, że brew ) na macOS, tak jak jestem całkowicie apt-get w Ubuntu i yummy > używam go na CentOS. Zalecałbym unikanie kompilowania rzeczy wywołanych przez surowy kod źródłowy w macOS, chyba że naprawdę masz jakikolwiek inny wybór.

Zwykle miałem wrażenie, że to pytanie dotyczy 3 miesięcy, ale dobrze znana odpowiedź to tak naprawdę tylko jednoznaczny wniosek z linku i że podpięcie w tej chwili nie działa. Kolejna nowa odpowiedź jest technicznie poprawna, ale nadal wyjaśnia, że ​​który konkretny praktyczny proces wymaga pobrania wersji GNU autoconf , automake . libtool wymagany również w systemie Mac OS X.

Po pierwsze, Xcode — myślę, że przynajmniej od stylu 3 — nie zawiera już typów GNU autoconf , automake i libtool . Oznacza to, że nie możesz samodzielnie zainstalować narzędzi GNU. I najlepiej, tak to wygląda.

Z tego planu korzystałem bez problemu w systemie Mac OS 10 x.6 (Snow Leopard), 10,7 (Lion), 10,8 (Mountain Lion) i 10,9 (Mavericks).

InstallXcode jako dodatek do narzędzi wiersza poleceń Xcode.

Pierwszym warunkiem jest to, że Xcode jest uważany za zainstalowany również z wierszami narzędzi słów poleceń Xcode. Jeśli ktoś potrzebuje nowych plików autoconf , automake , ale także libtool , potencjalni klienci mają już Xcode, dodatkowo zazwyczaj narzędzia wiersza poleceń… Wiedz, że dla tych, którzy są tam prawdę powiedziani, nie ma tej konfiguracji w tym momencie.

Cóż, przejdź do ekspozycji! Pamiętaj tylko, że numery produktów do pobrania są oparte na zaktualizowanym stanie (stan na kwiecień 2015 r.) i w rezultacie działały dobrze w okresie pisania tego tekstu. Dostosuj się do dodatkowych wersji, jeśli potrzebujesz autoconf dla:

Zainstaluj 2.69.

CD

  snuggle -O -L http://ftpmirror.gnu.org/autoconf/autoconf-2.69.tar.gztar -xzf autoconf-2.69.tar.gz 
  cd autoconf- *   ./configure Zrób 

  
  sudo make install 

Sprawdź swoją własną, nowo zainstalowaną wersję autoconf , aby upewnić się, że wszystko działa poprawnie:

  autoconf --version   

autokonf 2.69

Zainstaluj Automake 1.15.

CD

  curl -O -L http://ftpmirror.gnu.org/automake/automake-1.15.tar.gztar -xzf automake-1.15.tar.gz 
  CD-Automake- *   ./configure Zrób 

  
  sudo programowanie instalacji autoreconf wymaga nie znaleziono mac os x

Sprawdź moją nową alternatywę automake , aby upewnić się, że wszystko zostało dobrze umieszczone:

  automake --wersja  

automatyczne generowanie 1,15

Zainstaluj Libtool 2.4.6.

CD

  curl -OL http://ftpmirror.gnu.org/libtool/libtool-2.4.6.tar.gztar -xzf libtool-2.4.6.tar.gz 
  blu-ray libtool- * 

Napraw swój komputer teraz za pomocą Reimage

Czy Twój komputer działa wolno, ulega awarii lub wyświetla niebieski ekran śmierci? Nie bój się, pomoc jest tutaj! Dzięki Reimage możesz szybko i łatwo naprawić typowe błędy systemu Windows, chronić swoje pliki przed utratą lub uszkodzeniem oraz zoptymalizować komputer pod kątem maksymalnej wydajności. Więc nie męcz się dłużej z powolnym, przestarzałym komputerem — pobierz Reimage i odzyskaj swoje życie!

  • Krok 1: Pobierz i zainstaluj Reimage
  • Krok 2: Uruchom program i wybierz swój język
  • Krok 3: Postępuj zgodnie z instrukcjami wyświetlanymi na ekranie, aby rozpocząć skanowanie komputera w poszukiwaniu błędów

  • ./configure Zrób

      
    
      zainstaluj formularz sudo 
    

    Sprawdź wersję libtool , która została ostatnio skonfigurowana na stronie man witryny, aby upewnić się, że wszystko poszło, co wiesz:

      man libtool 
    

    Zdecydowanie na niektórych z pierwszych stron internetowych mężczyzna powinien mieć coś do bezpośredniej rozrywki:

    libtool - strona ludzkości do pobrania libtool 2.4.6

      npm I mozjpeg-binnpm OSTRZEŻENIE przestarzałe [email protected]: Graceful-fs v3.0.0 i wcześniejsze nie będą wykonywane na węźle> = v7.0. Zobacz rozpoczęte od [email protected]^4.0.0 JAK NAJSZYBCIEJ. Użyj "npm ls graceful-fs", aby wyświetlić go w odniesieniu do drzewa.> [email protected] postinstall / Users / me / project and node_modules / mozjpeg-bin> Węzeł Postinstall.jsBudowa ogólnie mózgu ...(węzeł: 2942) fs: Źródła na potrzeby rodzimego modułu przeszacowania nie zostały potwierdzone. Jeśli używasz całego modułu fs, zaktualizuj go do najlepszej nowszej wersji.✓— Komenda już się nie powiedzie: autoreconf -fiv && ./configure --prefix jest równy "/ Users / ja / upgrade / node_modules / mozjpeg-bin dla każdego bin" --bindir = "/ Users / moja wizja / projekt / node_modules lub mozjpeg - bin / bin "&& --libdir =" / users / ja i projekt / node_modules / mozjpeg-bin kontra bin "make install/ bin - sh: autoreconf: powiedz nie znajdź 
    

    Chcę uruchomić autoconf , automake , m4 , wiele innych... Xcode 4.2.1. Rrssue musi być tym, co próbuję lub instaluję, a dokładnie to powinno polegać na autoconf . Próbuję więc zainstalować program autoconf i mam:

      configure.ac:30: Automake 1.11 jest wymagany, ale 1.10 
    
      configure.ac:20: Błąd: Wymaga wersji Autoconf 2.68 prawdopodobnie wyższejconfigure.ac:20: najwyższy poziomautom4te: Błąd w porównaniu z usr / bin / gm4 przy statusie wyjścia: 63alocal.tmp: error: autom4te podchodzi do ściany ze statusem: ingate 63 nie znaleziono polecenia autoreconf pc os x

    Czy Twój komputer działa wolno? Napraw to za pomocą Reimage, jedynego oprogramowania, które może rozwiązać wiele problemów związanych z systemem Windows.

    Autoreconf Command Not Found Mac Os X
    Autoreconf Opdracht Niet Gevonden Mac Os X
    Autoreconf Befehl Nicht Gefunden Mac Os X
    Comando Autoreconf Nao Encontrado Mac Os X
    Commande Autoreconf Introuvable Mac Os X
    Komanda Autoreconf Ne Najdena Mac Os X
    Autoreconf 명령을 찾을 수 없습니다 Mac Os X
    Comando Autoreconf No Encontrado Mac Os X
    Comando Autoreconf Non Trovato Mac Os X
    Autoreconf Kommandot Hittades Inte Mac Os X