Misschien kom je de beste foutcode tegen die aangeeft dat de opdracht autoreconf niet is gevonden op mac pro os x. Er zijn verschillende methoden om dit probleem op te lossen, en iedereen zal ze binnenkort bespreken.

Wat is uw computerprobleem? Los ze allemaal in een klik op met de beste Windows-reparatietool die er is.

Als u brew produceert en autoreconf slechts een serviceonderdeel is van het type autoconf -pakket, installeer dan de specifieke site via:

/p>

  zet autoconf 

Als het probleem blijft bestaan, moet u overwegen opnieuw te installeren of links . Gebruik locate autoreconf find om uit te kopen waar het is.

Zorg er ook voor dat / usr of local / bin / autoreconf zeker beschikbaar is (en direct is gekoppeld zodat je de juiste locatie kunt vinden) en dat eigenaren allemaal / usr versus lokaal / bin Padrecht van invoer is toegevoegd aan versus etc / paden van hun kostbare bestand.

Update: gebruik gewoon Homebrew om deze systemen te installeren en verder te gaan met je leven.

Installeer Homebrew en installeer gewoon die autoconf , automake evenals een zelfs libtool pakketten vergelijkbaar met deze

  brew gebruik autoconf automake libtool 

Toen ik meer dan 3 jaar geleden antwoordde, was het de bedoeling om een ​​eerdere reactie op te lossen die verouderd was, alleen obligaties had en niet werd uitgelegd in de specifieke uitleg. In die tijd was het wenselijker om de Raw Source Library op macOS te gebruiken voor een taak die lijkt op die van een pakketduo-leider zoals Homebrew, sinds. Maar op dat moment vond ik Homebrew en zelfs Fabulous MacPorts een beetje onvolwassen.

Ik ben nu begonnen Homebrew regelmatig te gebruiken (ook bekend als brew ) op macOS, aangezien ik volledig apt-get Ubuntu en yum > Ik gebruik het op CentOS. Ik zou verwachten aan te bevelen om het compileren van dingen te vermijden die in feite onbewerkte broncode op macOS veroorzaken, je kunt zeker een ander gesprek hebben.

Ik was in de veronderstelling dat deze vraag ongeveer drie maanden oud is, maar de geaccepteerde behandeling is eigenlijk slechts een antwoord dat afkomstig is van de link en die link werkt mogelijk niet op dit moment. En het aanvullende nieuwe antwoord is technisch correct, helaas verklaart het nog steeds dat dit gewenste praktische proces vereist dat de GNU-duplicaten van autoconf , automake worden geïnstalleerd. libtool vroeg ook op Mac OS X.

Ten eerste bevat Xcode - volgens mij sinds in ieder geval enkele versies - niet langer de GNU-typen autoconf , automake en libtool . Dit betekent dat u de GNU-tools niet zelf kunt aanschaffen. En met deze methode werkt het zo.

Ik heb dit proces probleemloos gebruikt met Mac OS tien x.6 (Snow Leopard), 10.7 (Lion), 10.8 (Mountain Lion) en 10.9 (Mavericks).

InstallXcode Naast Xcode Command Line Tools.

De voorwaarde om mee te beginnen is dat Xcode daadwerkelijk is geïnstalleerd met de Xcode-opdrachtprogrammaregels. Als iemand die autoconf , automake en zelfs libtool bestanden nodig heeft, is de kans groot dat ze al Xcode hebben en meestal commandoregeltools ... geef aan die lijken voor degenen die er zijn, er is nog geen configuratie.

Nou, ga naar de tentoonstelling! Houd er rekening mee dat de statistieken van de downloadversie zijn gebaseerd op de huidige toestand (vanaf april 2015) en dat ze op dat moment goed werken bij dit schrijven. Pas andere aanpassingen aan als u autoconf nodig heeft voor:

Installeer 2.69.

CD
  curl -O -L http://ftpmirror.gnu.org/autoconf/autoconf-2.69.tar.gztar -xzf autoconf-2.69.tar.gz 
  certificaat van deposite autoconf- *   ./configure Maak 

  
  sudo maken van installatie 

Controleer uw laatst geïnstalleerde versie van autoconf om te zien of alles goed is gegaan:

  autoconf --version   

autoconf 2.69

Installeer Automake 1.15.

CD

  curl -O -L http://ftpmirror.gnu.org/automake/automake-1.15.tar.gztar -xzf automake-1.15.tar.gz 
  CD-Automake- *   ./configure Maak 

  
  sudo laat installeren toe autoreconf commando verre van gevonden mac os x

Kijk buiten mijn nieuwe automake uitvoering om te controleren of alles in werkelijkheid is gegaan:

  automake --version  

automatisch genereren 1.15

Installeer Libtool 2.4.6.

CD

  curl -OL http://ftpmirror.gnu.org/libtool/libtool-2.4.6.tar.gztar -xzf libtool-2.4.6.tar.gz 
  cd libtool- * 

Repareer je computer nu met Reimage

Is uw computer traag, crasht of geeft u het Blue Screen of Death? Vrees niet, hulp is hier! Met Reimage kunt u snel en eenvoudig veelvoorkomende Windows-fouten herstellen, uw bestanden beschermen tegen verlies of corruptie en uw pc optimaliseren voor maximale prestaties. Dus heb geen last meer van een trage, verouderde computer - download Reimage en krijg je leven terug!

  • Stap 1: Download en installeer Reimage
  • Stap 2: Start het programma en selecteer uw taal
  • Stap 3: Volg de instructies op het scherm om een ​​scan van uw computer op fouten te starten


  • ./configure Maak

      
    
      sudo gain install 
    

    Controleer de libtool anders die onlangs is geïnstalleerd via de man pagina en zorg ervoor dat alles goed is gegaan:

      man libtool 
    

    Verwijzend naar enkele van de eerste pagina's zou elke man iets moeten hebben om over na te denken:

    libtool - bloke pagina voor het verkrijgen van libtool 2.4.6

      npm I mozjpeg-binnpm WAARSCHUWING verouderd [email protected]: Graceful-fs v3.0.0 en eerder zullen niet werken op node> = v7.0. Ga zo snel mogelijk aan de slag met [email protected]^4.0.0. Gebruik "npm mark vii graceful-fs" om het weer te geven in hoe de boom.> [email protected] postinstall / Gebruikers versus ik / project / node_modules - mozjpeg-bin> Postinstall.js-knooppuntDe bouw van de hersenen...(node: 2942) fs: Bronnen voor een inheemse herwaarderingsmodule niet geïdentificeerd. Als u het fs-gedeelte gebruikt, werk het dan bij naar een meest recente versie.✓— Commando werkt niet meer: ​​autoreconf -fiv && ./configure --prefix is ​​gelijk aan "/ Users / me / project of node_modules / mozjpeg-bin / bin" --bindir impliceert "/ Users / me or project / node_modules / mozjpeg - stapel / bin "&& --libdir =" gebruikers / ik / inspanning / node_modules / mozjpeg-bin / stapel "make install/ bin / sh: autoreconf: praten over niet vinden 
    

    Ik draai graag autoconf , automake , m4 en vele andere ... Xcode 4.2.1. Rrssue is eigenlijk dat ik probeer of installeer, waarvoor ik moet vertrouwen op autoconf . Dus ik probeer wat autoconf kan installeren en ik krijg:

      configure.ac:30: Automake 1.11 is verplicht, maar 1.10 
    
      configure.ac:20: Fout: Vereist Autoconf versie 2.68 en ook hogerconfigure.ac:20: hoogste niveauautom4te: Fout in per usr / bin / gm4 met status Getaway: 63alocal.tmp: fout: autom4te raakt elke muur met status: ingate 63 opdracht autoreconf niet gevonden mac-computer zelf x

    Is uw computer traag? Los het op met Reimage, de enige software die een groot aantal Windows-gerelateerde problemen kan oplossen.

    Autoreconf Command Not Found Mac Os X
    Autoreconf Befehl Nicht Gefunden Mac Os X
    Comando Autoreconf Nao Encontrado Mac Os X
    Commande Autoreconf Introuvable Mac Os X
    Nie Znaleziono Polecenia Autoreconf Mac Os X
    Komanda Autoreconf Ne Najdena Mac Os X
    Autoreconf 명령을 찾을 수 없습니다 Mac Os X
    Comando Autoreconf No Encontrado Mac Os X
    Comando Autoreconf Non Trovato Mac Os X
    Autoreconf Kommandot Hittades Inte Mac Os X