Puoi connetterti con un codice di errore che indica che il comando specifico autoreconf non è stato trovato su mac os x. Esistono molti modi per risolvere questo problema e, inoltre, ne parleremo a breve.

Qual è il tuo problema con il computer? Risolvili tutti in un clic con il miglior strumento di riparazione di Windows in circolazione.

Se stai eseguendo brew e autoreconf è una parte di servizio relativa al pacchetto autoconf , scegli il sito tramite:

  make install autoconf 

Se il punto persiste, dovresti considerare di reinstallare o link . Usa locate autoreconf find in modo che scopra dove si trova.

Assicurati inoltre che e usr / local / bin e autoreconf esistano (e sia collegato immediatamente alla posizione corretta) e che tutti voi possiedate per ogni usr / local / bin È stato aggiunto l'accesso al percorso e / etc / percorsi provenienti da tutto il tuo prezioso file.

Aggiornamento: usa Homebrew per installare questi sistemi e andare avanti con la tua vita.

Installa Homebrew e installa un autoconf , automake per non parlare nemmeno di libtool molto come questo

  brew build autoconf automake libtool 

Quando ho risposto più di 3 anni fa, un'idea era quella di riparare una soluzione più veloce che era obsoleta, aveva collegamenti principali e non era stata spiegata l'ultima spiegazione. All'epoca, preferivo usare la Raw Source Library su macOS per una procedura simile a quella di un leader di un team affare come Homebrew, dal momento che, avendo il tempo, ho appena trovato Homebrew e Fabulous MacPorts un po' prematuro.

Ora ho iniziato a usare regolarmente Homebrew (noto anche come brew ) su macOS poiché sono completamente apt-get su Ubuntu e buonissimo > Lo uso su CentOS. Consiglierei di evitare di compilare cose consentite dal codice sorgente non elaborato su macOS a meno che tu non abbia davvero qualche altra scelta.

Avevo l'impressione che questa domanda fosse sull'argomento di 3 mesi, ma la risposta diffusa è in realtà solo una conclusione chiara dal link e quella connessione non funziona in questo momento. E un'altra nuova risposta è tecnicamente ideale, ma spiega comunque che questo consiglio particolare processo pratico richiede che le versioni GNU di autoconf , automake siano fissate. libtool richiesto anche su Mac OS X.

Primo, Xcode - credo che almeno dalla variazione 3 - non contenga più i suoi tipi GNU autoconf , automake e libtool . Ciò significa che non sarai in grado di installare gli strumenti GNU da solo. E idealmente, è così che funziona.

Ho utilizzato questa procedura senza problemi con Mac OS 10 x.6 (Snow Leopard), 10.7 (Lion), 10.8 (Mountain Lion) e 10.9 (Mavericks).

InstallXcode in aggiunta agli strumenti della riga di comando di Xcode.

La prima condizione è che Xcode sia veramente installato anche con le linee di strumenti di gestione di Xcode. Se qualcuno ha bisogno di ogni autoconf , automake anche libtool file, apparato . hanno già Xcode come di solito gli strumenti da riga di comando ... tagga che per quelli che si trovano in quella posizione, non c'è mai questa configurazione.

Bene, vai al display! Basta notare che i numeri di adattamento del download si basano sullo stato dell'elettricità (ad aprile 2015) e quindi funzionavano bene nel tempo libero in cui scriviamo. Adatta ad altri tipi di versioni se hai bisogno di autoconf per:

Installa 2.69.

CD
  coccola -O -L http://ftpmirror.gnu.org/autoconf/autoconf-2.69.tar.gztar -xzf autoconf-2.69.tar.gz 
  cd autoconf- *   ./configure Crea 

  
  sudo make install 

Controlla una nuova versione appena installata di autoconf per assicurarti che tutto sia andato a buon fine:

  autoconf --version   

autoconf 2.69

Installa Automake 1.15.

CD
  curl -O -L http://ftpmirror.gnu.org/automake/automake-1.15.tar.gztar -xzf automake-1.15.tar.gz 
  CD-Automake- *   ./configure Crea 

  
  sudo help make install autoreconf direction not found mac os x

Dai un'occhiata al mio nuovo tipo automake per assicurarti che tutto sia stato eliminato bene:

  automake --version  

generazione automatica 1.15

Installa Libtool 2.4.6.

CD
  curl -OL http://ftpmirror.gnu.org/libtool/libtool-2.4.6.tar.gztar -xzf libtool-2.4.6.tar.gz 
  cd / dvd libtool- * 

Ripara ora il tuo computer con Reimage

Il tuo computer è lento, si blocca o ti dà la schermata blu della morte? Non temere, l'aiuto è qui! Con Reimage, puoi riparare rapidamente e facilmente gli errori comuni di Windows, proteggere i tuoi file da perdita o danneggiamento e ottimizzare il tuo PC per le massime prestazioni. Quindi non soffrire più con un computer lento e obsoleto: scarica Reimage e riprenditi la vita!

  • Passaggio 1: scarica e installa Reimage
  • Fase 2: avvia il programma e seleziona la tua lingua
  • Passaggio 3: segui le istruzioni sullo schermo per avviare una scansione del tuo computer alla ricerca di errori

  • ./configure Crea

      
    
      sudo provide install 
    

    Controlla la versione libtool che è stata aggiunta di recente tramite la pagina man del sito per assicurarti che tutto sia andato a buon fine:

      man libtool 
    

    Sicuramente in alcune delle prime fan page un uomo dovrebbe avere finalmente qualcosa da divertire:

    libtool - pagina jeder per ottenere libtool 2.4.6

      npm I mozjpeg-binnpm AVVISO deprecato [email protected]: Graceful-fs v3.0.0 e precedenti non verranno eseguiti su node> = v7.0. Si prega di acquistare iniziato con [email protected]^4.0.0 al più presto. Usa "npm ls grazioso-fs" per visualizzarlo nell'albero.> [email protected] postinstallazione / Utenti / me / progetto contro node_modules / mozjpeg-bin> Nodo Postinstall.jsCostruzione del Cervello specifico...(nodo: 2942) fs: Fonti a favore del modulo di rivalutazione indigeni non confermate. Se stai usando questo modulo fs, aggiornalo a una versione più recente.✓— Il comando non funziona più: autoreconf -fiv && ./configure --prefix implica "/ Users / me / design / node_modules / mozjpeg-bin bin" --bindir = "/ Users / me and my friends / project / node_modules per ogni mozjpeg - bin / bin "&& --libdir =" / utenti / me per progetto / node_modules / mozjpeg-bin bin "make install/ bin o sh: autoreconf: dire di non trovare 
    

    Voglio eseguire autoconf , automake , m4 e molti altri... Xcode 4.2.1. Rrssue è diventato tutto ciò che provo o installo, che generalmente dovrebbe fare affidamento su autoconf . Quindi provo cosa può installare autoconf e prendo:

      configure.ac:30: Automake 1.11 potrebbe essere richiesto, ma 1.10 
    
      configure.ac:20: Errore: richiede Autoconf versione 2.68 o successivaconfigure.ac:20: livello superioreautom4te: Errore in versus usr/bin/gm4 combinato con lo stato di uscita: 63alocal.tmp: errore: autom4te attiva un muro con stato: ingate 63 comando autoreconf non trovato mac computer os x

    Il tuo computer è lento? Risolvilo con Reimage, l'unico software in grado di risolvere un'ampia gamma di problemi relativi a Windows.

    Autoreconf Command Not Found Mac Os X
    Autoreconf Opdracht Niet Gevonden Mac Os X
    Autoreconf Befehl Nicht Gefunden Mac Os X
    Comando Autoreconf Nao Encontrado Mac Os X
    Commande Autoreconf Introuvable Mac Os X
    Nie Znaleziono Polecenia Autoreconf Mac Os X
    Komanda Autoreconf Ne Najdena Mac Os X
    Autoreconf 명령을 찾을 수 없습니다 Mac Os X
    Comando Autoreconf No Encontrado Mac Os X
    Autoreconf Kommandot Hittades Inte Mac Os X