Möglicherweise wird ein bestimmter Fehlercode angezeigt, der darauf hinweist, dass das Autoreconf-Befehlswort auf dem Mac-Betriebssystem x nicht gefunden wurde. Es gibt mehrere Möglichkeiten, dieses Problem zu lösen, und wir werden sie in Kürze besprechen.

Was ist Ihr Computerproblem? Lösen Sie sie alle mit einem Klick mit dem besten Windows-Reparaturtool, das es gibt.

Wenn Sie drink verwenden und autoreconf zu einem Serviceteil des exakten autoconf -Pakets geworden ist, installieren Sie die Internetseiten über:

  brew wähle autoconf 

Wenn das Problem weiterhin besteht, sollte Ihr Unternehmen in Betracht ziehen, neu zu installieren oder links zu installieren. Verwenden Sie seek autoreconf find , um herauszufinden, wo sich die Seite befindet.

Versuchen Sie auch sicherzustellen, dass / usr / / bin / autoreconf gefunden werden kann (und direkt mit diesem korrekten Speicherort verknüpft ist) und dass Sie jeden einzelnen von / usr / Domestic / bin Der Pfadzugriff wurde zu / viele / paths Ihrer Festplatte hinzugefügt.

Update: Verwenden Sie einfach Homebrew, um diese Systeme zu installieren und mit Ihrem Leben weiterzumachen.

Installieren Sie Homebrew und installieren Sie einfach die Pakete autoconf , automake und jetzt sogar libtool

  brew install autoconf automake libtool 

Als ich vor 3 Jahren antwortete, war die Idee im Grunde, eine frühere Lösung zu reparieren, die veraltet war, nur Links hatte und daher nicht in den Beweisen erklärt wurde. Zu der Zeit zog ich es vor, die Raw Source Library nach macOS für eine ähnliche Aufgabe wie die eines Paket-Team-Standards wie Homebrew zu verwenden, da ich Homebrew und Fabulous MacPorts mit der Zeit etwas unausgereift fand.

Ich habe jetzt begonnen, regelmäßig in Homebrew (auch bekannt als drink) auf macOS zu investieren, da ich jetzt vollständig auf Ubuntu apt-get bin und yum> zeichne ich auf CentOS auf. Ich würde empfehlen, das Kompilieren von Dingen zu vermeiden, die durch ungekochten Quellcode unter macOS verursacht werden, es sei denn, Sie müssen wirklich eine andere Wahl haben.

Ich hatte den Eindruck, dass diese Frage ungefähr 3 Jahre alt ist, aber die akzeptierte Antwort könnte tatsächlich nur eine Antwort von dem genauen Link sein, und dieser Link funktioniert nicht gerade. Und eine weitere zusätzliche Antwort ist technisch korrekt, aber alles erklärt immer noch, dass dieser spezielle praktikable Prozess die Installation der GNU-Versionen erfordert, die mit autoconf , automake zusammenhängen. libtool obligatorisch auch unter Mac OS X.

Erstens enthält Xcode - ich seit mindestens Version 8 - nicht mehr die GNU-Muster autoconf, automake sowie libtool. Das bedeutet, dass Sie selbst kein GNU-Tool installieren können. Und im Idealfall ist es so, wie es funktioniert.

Ich habe diesen Prozess ohne Probleme mit Mac OS 10 x.6 (Snow Leopard), 10.7 (Lion), 10.8 (Mountain Lion) und 10.9 (Mavericks) verwendet.

Installieren Sie Xcode zusätzlich zu den Xcode-Befehlszeilentools.

Die erste Krankheit ist, dass Xcode auch mit den Xcode-Befehlswerkzeugsystemen erstellt wird. Wenn jemand die autoconf -, automake - und libtool -Dateien benötigt, stehen die Chancen gut, dass er bereits Xcode hat und normalerweise Zeilentools anfordert ... geben Sie das an, wenn diejenigen, die da sind, gibt es noch sehr viel nicht diese Konfiguration.

Nun, gehen Sie zur Ausstellung! Geben Sie einfach an, dass die Download-Versionsnummern weiterhin auf dem aktuellen Stand (Stand April 2015) basieren und zum Zeitpunkt der Erstellung dieses wertvollen Artikels in Ordnung waren. Passen Sie sich an andere Versionen an, falls Sie autoconf über Folgendes benötigen:

Installieren Sie 2.69.

CD
  curl -O -L http://ftpmirror.gnu.org/autoconf/autoconf-2.69.tar.gztar -xzf autoconf-2.69.tar.gz 
  cd dvd autoconf- *   ./configure Machen Sie 

  
  sudo initiiert die Installation 

Überprüfen Sie Ihre neu installierte Version von autoconf , um sicherzustellen, dass alles gut gelaufen ist:

  autoconf --version   

autoconf 2.69

Installieren Sie Automake 1.15.

CD
  curl -O -L http://ftpmirror.gnu.org/automake/automake-1.15.tar.gztar -xzf automake-1.15.tar.gz 
  CD-Automake- *   ./configure Machen Sie 

  
  sudo make install autoreconf-Befehl nicht ermittelt mac os x

Sehen Sie sich ein paar neue Versionen von automake an und vergewissern Sie sich, dass alles gut gelaufen ist:

  automake --version  

Automatische Generierung 1.15

Installieren Sie Libtool 2.4.6.

CD
  curl -OL http://ftpmirror.gnu.org/libtool/libtool-2.4.6.tar.gztar -xzf libtool-2.4.6.tar.gz 
  cd libtool- * 

Reparieren Sie Ihren Computer jetzt mit Reimage

Läuft Ihr Computer langsam, stürzt er ab oder zeigt Ihnen den Blue Screen of Death? Keine Angst, Hilfe ist da! Mit Reimage können Sie häufige Windows-Fehler schnell und einfach beheben, Ihre Dateien vor Verlust oder Beschädigung schützen und Ihren PC für maximale Leistung optimieren. Leiden Sie also nicht länger unter einem langsamen, veralteten Computer - laden Sie Reimage herunter und holen Sie sich Ihr Leben zurück!

  • Schritt 1: Reimage herunterladen und installieren
  • Schritt 2: Starten Sie das Programm und wählen Sie Ihre Sprache aus
  • Schritt 3: Befolgen Sie die Anweisungen auf dem Bildschirm, um Ihren Computer auf Fehler zu scannen


  • ./configure Machen Sie

      
    
      sudo make install 
    

    Überprüfen Sie das kürzlich installierte libtool -Modell über die man -Seite, um sicherzustellen, dass alles gut gelaufen ist:

      wow libtool 
    

    Definitiv auf ausgewählten der ersten Seiten sollte ein Kerl etwas zu amüsieren haben:

    libtool - manuelles Formular zum Abrufen von libtool 2.4.6

      npm ich mozjpeg-binnpm WARNUNG veraltet [email protected]: Graceful-fs v3.0.0 und auch früher funktionieren nicht mit node> = v7.0. Beginnen Sie bitte so schnell wie möglich mit [email protected]^4.0.0. Verwenden Sie "npm mark vii graceful-fs", um es in einer Art Baum anzuzeigen.> [email protected] postinstall / Benutzer / meine Meinung / Projekt / node_modules mozjpeg-bin> Postinstall.js-KnotenKonstruktion des Gehirns ...(Knoten: 2942) fs: Quellen für das native Neubewertungsmodul nicht identifiziert. Wenn Sie dann das fs-Modul verwenden, müssen Sie es auf eine neue Version aktualisieren.✓— Befehl funktioniert nicht mehr: autoreconf -fiv && ./configure --prefix = "/ Users / me / project per node_modules / mozjpeg-bin / bin" --bindir bedeutet "/ Users / me / work / node_modules / mozjpeg - tray/bin "&& --libdir=" oder users/me/project per node_modules/mozjpeg-bin/trash "make install/bin/sh: autoreconf: sag ihm nicht gefunden 
    

    Ich möchte, dass Sie autoconf , automake , m4 und ... Xcode 4.2.1 ausführen können. Rrssue ist, was immer ich versuche oder installiere, das auf autoconf warten sollte. Also probiere ich aus, was autoconf leicht installieren kann, und ich bekomme:

      configure.ac:30: Automake 1.11 wird benötigt, sondern 1.10 
    
      configure.ac:20: Fehler: Benötigt Autoconf Version 2.68 oder höherconfigure.ac:20: Hauptebeneautom4te: Fehler in /usr pro bin /gm4 mit Exit-Rang: 63alocal.tmp: error: autom4te hit a partitions with status: ingate 63 autoreconf hat Mac-Betriebssystem x nicht gefunden

    Läuft Ihr Computer langsam? Beheben Sie es mit Reimage, der einzigen Software, die eine Vielzahl von Windows-bezogenen Problemen beheben kann.

    Autoreconf Command Not Found Mac Os X
    Autoreconf Opdracht Niet Gevonden Mac Os X
    Comando Autoreconf Nao Encontrado Mac Os X
    Commande Autoreconf Introuvable Mac Os X
    Nie Znaleziono Polecenia Autoreconf Mac Os X
    Komanda Autoreconf Ne Najdena Mac Os X
    Autoreconf 명령을 찾을 수 없습니다 Mac Os X
    Comando Autoreconf No Encontrado Mac Os X
    Comando Autoreconf Non Trovato Mac Os X
    Autoreconf Kommandot Hittades Inte Mac Os X